ArcGIS Version Support Details

Jonathan Semones -

Software Support and Technical Assistance

The information below outlines the support levels currently offered for current and historical releases of Lucity software and ArcGIS. If you have any questions, please contact us.

Information about supported Lucity versions

Release Date   6/17 12/16 5/16 2/16 5/15 12/14 4/14 1/14 7/13 6/12 6/10
  Version 10.5.1 10.5.0 10.4.1 10.4.0 10.3.1 10.3.0 10.2.2 10.2.1 10.2.0 10.1.0 10.0.0
TBA 2017r2 **
2/17 2017 **
8/16 2016r2 **
3/16 2016 **
8/15 2015r2 **
2/15 2015 ** * * *
8/14 2014r2 **
2/14 2014 **

 

 

Support Policy

Description

Supported at Lucity Release (sp0)

Supported post Lucity Release (sp1+)

Not officially supported, but no issues expected.  Refer to the Version Support Details to check the support status of the Lucity Version.

Not supported 

* - Some Lucity GIS and Mobile features require ArcGIS 10.2.2 or higher.

** - ArcGIS Desktop 10.4 only.  ArcGIS for Server 10.4 is not supported.

Have more questions? Submit a request

Comments

  • Avatar
    Blake Terhune

    This version support matrix is exactly what I was looking for. Thank you for putting this together and keeping it up to date!